[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [NOVICE] Opdaterings problemer på en Debian



On Sat, 19 Feb 2005 13:11:16 +0100, Allan Kok wrote:

> Min debian er begyndt at komme med en fejl meddelse, når jeg prøver at 
> opdatere pakker med "apt-get upgrade"
> 
> Setting up passwd (4.0.3-30.9) ...
> dpkg: error processing passwd (--configure):
>  subprocess post-installation script killed by signal (Illegal instruction)
> Errors were encountered while processing:
>  passwd
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> 
> Hvordan kan denne fejl afhjælpes?
> 
> PS. den kører testing på en alpha!
> 
> mvh
> Allan
> 
> 
> 

Det hvad din fejl-melddelese betyder, er at en ny installeret pakke
passwd (som indeholder alt muligt nødvendig med hensyn til bruger
verificering) dør på post-install scriptet, som skal sætte den ny
passdw pakke op efter installation. 

Umiddelbart har du ikke store chancer for at få denne installeret - men
du kan downgrade til den version i debian stable.

Det gør du ved at tilføje linierne 


Package: passwd
Pin: release a=stable
Pin-Priority: 1100

i en nyoprettet fil /etc/apt/preferences

og addere linier indeholdende 'stable´ istedetfor 'testing' i din
/etc/apt/sources.list 


Så kører du 

apt-get update
apt-get install passwd

og burde være ned på en version der funker på din alpha.

Test lige med -s (for simulere) option, før du gør det - bare for at
se om tingene flasker sig.

Se http://debianguiden.dk/dists/stable/html/apt-og-dpkg.html#apt-recovery
og diverse man pages for info.

Og så skal du selvføgelig huske at rapportere fejlen til debian, det
gøres nemt med

komandoen reportbug fra samme pakke (som så fejlagtig vil raportere den
downgradede versionsnummer, men det kan du nemt rette i editoren der
kommer op.)


hilsen, Marc



 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 21:20 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *