[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [TEKNIK] sendmail opsætning



"David List" <sslug@sslug> skrev i en meddelelse
news:sslug@sslug
> Jeg kan se at mails bliver hentet med fetchmail uden problemer, og
sendmail
> bliver også bedt om at fordele disse mails (fra linier i /etc/ppp/ip-up),
> men af /var/log/mail kan jeg se at sendmail ikke engang forsøger. Der
bliver
> sagt: "root...Recipient names must be specified.".
> Nu er det, jeg mener at have gjort det samme som fungerede under 6.2, og
> derfor ikke kan gennemskue hvad jeg mangler. Jeg har sat de
> sendmail-relaterede parametre fra YaST, som man skal ifølge manualen med
en
> dial-up forbindelse, og jeg har lavet virtusertable.db og genericstable.db
> ifølge manualen, for at få brugerne genkendt som deres respektive
> mail-adresser.


Nu kan jeg sende mellem brugerne (root inkl.) på systemet, og headers bliver
korrekt ændret jvf. virtusertable og genericstable. Der er blot det, at jeg
ikke kan få fordelingen udført v.h.a. /usr/sbin/sendmail, men er nødt til at
genstarte sendmail ved at skrive "/sbin/init.d/sendmail stop" og
"/sbin/init.d/sendmail start". Først da modtager de respektive brugere
test-mails. Men stadig ikke de mails, der er blevet hentet af fetchmail
udefra.
De skulle jo så ligge i /var/spool/mqueue. Her finder jeg et
biblioteks-hierarki, som rekursivt gengiver domænenavnet på den smtp-server,
jeg har fortalt YaST skal være smarthost for sendmail. Nederst i hierarkiet
er en fil med nonsens i. Jeg synes at kunne huske fra tidligere at man
skulle kunne finde noget, hvor man kunne læse headers o.l.?

Er der nogen, der kan gennemskue hvad der går galt?

Med venlig hilsen
David List




 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 21:38 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *