[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [TEKNIK] HP PSC 2350 og linux



Jørgen Heesche wrote:
Hej.

Kan HP PSC 2350 multifunktionsprinter anvendes i Mandrake 9.1
(kernel 2.4.21) ?, når den er nævnt på
'Hewlett-Packard Linux Imaging and Printing Project: Product Support'
http://hpinkjet.sourceforge.net/hplip_readme.html#Device
Der skal øjensynligt installeres hplib, hvilket kan medføre, at der skal foretages visse opdateringer. F.eks. af CUPS: Hplib forlanger CUPS 1.15, jeg har CUPS 1.1.19.
Jeg er dog lidt usikker mht.CUPS. Ved søgning på http://rpmfind.net/ findes CUPS-versioner 1.1.6 til 1.1.23. Hvor passer CUPS 1.15, som nævnes på System Requirements
http://hpinkjet.sourceforge.net/hplip_readme.html#System
ind i den serie?

Tag et kig på http://www.linuxprinting.org - foomagic.
Direkte søgning efter printermodel, her min PCS 2410, som der ikke findes en driver til, derfor PCS 2400:
http://www.linuxprinting.org/show_printer.cgi?recnum=HP-PSC_2400



Fra min egen Slack-cups howto (non-released:


-----------
Using http://scumbag.onscreen.zzz:621, I started off reading relevant parts of
Administrator and User Documentation, then clicked on to Add Printer.


Neither this guide, nor the docs tell much about what's supposed to be filled in,
so I make a sample with what seemed logical - YMMV.
There was no driver for my HP psc 2410 Photosmart, so I initially chose HP 2500.


Printing a testpage made the printer react, but wrong = no print.
On www.linuxprinting.org, I located the page from where to search a specific printer.
( Full URL: http://www.linuxprinting.org/show_printer.cgi?recnum=HP-PSC_2400 )
I then located the page using foomagic to generate ppd' config files,
and downloated a ppd for psc 2400 - the closest definition.
( Full URL: http://www.linuxprinting.org/show_driver.cgi?driver=hpijs )


I didn't find any references in the docs as where to install the downloaded ppd file.
Turned out the belong in /etc/cups/ppd/ directory.
Would be nice with a tool to add new ppd's to /etc/cups/ppds.dat .
After changing the ppd definition in /etc/printers.conf to
<DefaultPrinter HP-PSC_2400-hpijs>
I was able to print a testpage.
I then renamed HP-PSC_2400-hpijs.ppd to HP-PSC_2410-hpijs.ppd, to reflect the printername,
and likewise in printers.conf to <DefaultPrinter HP-PSC_2410-hpijs> .
-----------



-- Kind regards, Mogens Valentin Networking, Security www.danbbs.dk/~monz Phone +45 32 525 878



 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2005-08-10, 22:26 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *