[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Bizar amd automount




Vi har en enkelt server som kører Redhat Enterprise 4, lige pt. er det eneste som kører på den en webserver som styrer vores brugerhjemmesider (det er dog meningen at der skal flere kritiske applikationer til at køre på denne server).


Her er nu mit problem. Som nævnt kører serveren den af vore to webservere som styrer vores brugerhjemmesider. Normalt ligger de jo så som domain.com/~user, hvor vi så har lavet lidt mod_rewrite så disse i stedet bliver til domain.com/user (hvis det har nogen betydning). Brugerhjemmesiderne er desuden konfigureret med 'SymLinksIfOwnerMatch' hviket jo er rimeligt nok.

Alle bruger data ligger NFS monteret fra vores filserver. Der er tre partitioner, lad os kalde dem A, B og C.

Jeg kan nu jævnligt se i error_log på min apache noget lignende

[Wed Jun 14 03:53:26 2006] [error] [client 67.175.195.180] Symbolic link not allowed: /home/user

Hvis man så kigger efter på systemet så skyldes dette problem tilsyneladende at amd enten i visse tilfælde ikke kan finde ud af at aumontere en partition ordentligt eller også ikke kan finde ud af at montere en partition ordentligt. I hvertfald er partitionen hvor brugeren 'user' bor ikke blevet monteret. Og den vil tilsynelande ikke montere den ordentligt.

Normalt monteres partitionerne under

/a/brugere/filservernavn/raid/A,B,C

og /home/user til så et softlink indtil en af disse (det er vist standard måden tingene sker på).

Når vi har et problem, så kan man se at rettighederne på mountpointet som hører til den partition som ikke vil montere bliver

dr-xr-xr-x

i stedet for de normale

drwxr-xr-x


Det sjove er at vi også kan gå til filerne via en /net/servernavn ... montering, og her monteres alt fint. En anden bizar ting er at det umiddelbart kun er denne maskine som har problemet. Men da vi har flere andre Redhat Enterprise 4 servere, så er jeg en smule bekymret (jeg formoder at denne er specielt ramt idet webserveren trækker så meget I/O).


Jeg ville gerne høre om der er andre som har haft lignende problemer samt om nogen har ideer til hvordan man får dette problem fikset.


/daleif

``You cannot help men permanently by doing for them
what they could and should do for themselves. ''
 -- Abraham Lincoln


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2006-07-01, 02:02 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *