[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [TEKNIK] telenor mobilt bredbånd



Martin Schlander wrote:
Atte André Jensen wrote:
3) kørte "sudo usb_modeswitch", med dimsen i hvilket som nævnt skifter
dimsen over i modem-mode. Det ser ud til at dette desværre skal gøres
hver gang dimsen har været ude, eller computeren slukket.

Det er beskrevet på et af de links jeg postede tidligere hvordan man kan automatisere det med udev-regler.

Det kan jeg simpelthen ikke få til at virke, har tilføjet følgende (en
linje) til  /etc/udev/rules.d/usb_modeswitch.rules:

SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1446",
RUN+="/usr/sbin/usb_modeswitch "

idVendor og idProduct svarer til hvad lsusb angiver:
sslug@sslug:~$ lsusb | grep Hua
Bus 002 Device 004: ID 12d1:1446 Huawei Technologies Co., Ltd.

RUN er blot sti til usb_modeswitch:
sslug@sslug:~$ which usb_modeswitch
/usr/sbin/usb_modeswitch

Oprindeligt var linjen kopieret fra en anden Huawei enhed længere oppe i
filen, men jeg prøvede at køre det der stod i RUN (med tilrettet
idVendor og idProduct) men usb_modeswitch brokkede sig over parameteren
"--detach-storage-only", så den smed jeg væk, og beholdt
"--default-vendor 0x12d1" og "--default-product 0x1446". Det virkede
heller ikke, og kørt i en term kom usb_modeswitch med en fejl.

Nogle gange ser det ud til at jeg skal køre usb_modeswitch to gange før det virker. Indtil videre har jeg lavet et lille script som kører usb_modeswitch, venter 5 sekunder og prøver igen indtil dimsen er i Modem mode. Men automatisk opsætning ville naturligvis være lækkert...

--
Atte


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2010-01-01, 02:01 CET [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *